RibbonGenerator build not working on Visual Studio Community 2015

Aug 31, 2016 at 10:57 AM
I would like to reopen this post: http://officeribbon.codeplex.com/discussions/647756
I am using MS VS Community 2015 on Windows 10. I tried to install RibbonLib v2.6 using this tutorial: https://bernhardelbl.wordpress.com/2010/11/17/quickstart-tutorial-windows-ribbon-for-winforms/. First of all, I tried to open RibbonGenerator.sln with Microsoft Visual Studio Version Selector, but MS VS 2010 Shell returned an error "Invalid license data. Reinstall is required". I looked it up, and then I tried solutions posted here: http://stackoverflow.com/questions/2673275/how-do-i-fix-an-invalid-license-data-reinstall-is-required-error-in-visual-c. Editing registry keys didn't work at all. Then I tried editing solution file and changed "# Visual Studio 2010" to "# Visual Studio 2015". Then, the solution has loaded with a warning, that it is unsupported. When I changed Solution Configuration to Release and then tried building it, I received 8 errors. I uploaded them here:

Do you have any experience with using this library on VS Community 2015 and could help me?
Sep 15, 2016 at 8:48 PM
Hi. I'm a brazilian guy, so forgive my English rsrs

So, just build solution and add a Reference on the desire project from the Ribbon35.dll file...

After you need to create a tab on toolbox (right click > Add Tab) then you need to righ click and "Choose items" and load from the same dll

the component you need is just Ribbon.... drag to your form and on propierties tab you can add tabs, panels, etc...

If you need the dll file, i send to you... just let me know!
Oct 4, 2016 at 7:02 AM
Hi, it seems I can't make work the Ribbon in Cummunity 2015 aswell. I can make the control tab appear and add the control to the form, but as soon as I add a tab, it is badly rendered, overlapped with the orb button. From then it is impossible to do anything more.

I tried what jhonsreis told but I can't add the Reference to the project. When I browse to the Ribbon35.dll, it does nothing.

Any suggestions? Step by step guide will be appreciated.

Thank you!